OpenRoads Designer CONNECT Edition SDK Help

CreateTangentCircularArcTwoElementsByLength Method

Constructs Vertical circle tangent to two elements and projected length.

Definition

Namespace: Bentley.CifNET.LinearGeometry Assembly: Bentley.CifNET.LinearGeometry.4.0 (in Bentley.CifNET.LinearGeometry.4.0.dll) Version: 1.0.0.0 (99.99.99.99)

C#

public static  ProfileCircularArc CreateTangentCircularArcTwoElementsByLength( ProfileElement elmt1, ProfileElement elmt2,double projectLength, BulgeOrientation bulge)

Parameters

SettingDescription
  ProfileElement Element circle is tangent to
  ProfileElement Element circle is tangent to
   Projected length
  BulgeOrientation Bulge orientation

Return Value

ProfileCircularArc Solution (if exist)

See Also